$re = '/Name: (?<name>[^\n]+)[\n\r]+Email: (?<email>[^\n]+)[\n\r]+Phone: (?<phone>[^\n]+)[\n\r]+Business: (?<business>[^\n]+)[\n\r]+Message: (?<message>[^\n]+)/m';
$str = 'Name: John Smith
Email: sitelab@gmail.com
Phone: 0952145879
Business: Marketing agency
Message: I’m interested in your services';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);