using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Name: (?<name>[^\n]+)[\n\r]+Email: (?<email>[^\n]+)[\n\r]+Phone: (?<phone>[^\n]+)[\n\r]+Business: (?<business>[^\n]+)[\n\r]+Message: (?<message>[^\n]+)";
string input = @" <link rel=""canonical"" href=""https://autojapan.com.ua/zapchastyna-219-KITAJ-KD312615XA/"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}