import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Name: (?<name>[^\\n]+)[\\n\\r]+Email: (?<email>[^\\n]+)[\\n\\r]+Phone: (?<phone>[^\\n]+)[\\n\\r]+Business: (?<business>[^\\n]+)[\\n\\r]+Message: (?<message>[^\\n]+)";
final String string = " <link rel=\"canonical\" href=\"https://autojapan.com.ua/zapchastyna-219-KITAJ-KD312615XA/\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}