// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Name: (?<name>[^\n]+)[\n\r]+Email: (?<email>[^\n]+)[\n\r]+Phone: (?<phone>[^\n]+)[\n\r]+Business: (?<business>[^\n]+)[\n\r]+Message: (?<message>[^\n]+)").unwrap();
let string = " <link rel=\"canonical\" href=\"https://autojapan.com.ua/zapchastyna-219-KITAJ-KD312615XA/\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}