import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<File>\\s+now/best\\s+size/ext\\s+(\\S+)\\s+(\\d+|\\-)/(\\d+|\\-)\\s+\\-\\s+Done\\.";
final String string = "<File> now/best size/ext\n"
+ ".abc 5/5 -\n"
+ "Done.\n\n"
+ "<File> now/best size/ext\n"
+ ".def 5/5 50m\n"
+ "Done.\n\n"
+ "<File> now/best size/ext\n"
+ ".ghi 5/5 -\n"
+ "Done.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}