import re
regex = re.compile(r"<File>\s+now/best\s+size/ext\s+(\S+)\s+(\d+|\-)/(\d+|\-)\s+\-\s+Done\.", flags=re.MULTILINE)
test_str = ("<File> now/best size/ext\n"
".abc 5/5 -\n"
"Done.\n\n"
"<File> now/best size/ext\n"
".def 5/5 50m\n"
"Done.\n\n"
"<File> now/best size/ext\n"
".ghi 5/5 -\n"
"Done.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")