#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?Ux)=\?(?<charset>[^\?]+)\?(?<code>[qQbB])\?(?<text>[^\?]+)\?=(?:[ ]+(?==\?))?"
Local $sString = "=?utf-8?b?foo?= =?utf-8?B?bar?= more no q encoded =?latin-1?Q?another?="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")