const regex = /=\?(?<charset>[^\?]+)\?(?<code>[qQbB])\?(?<text>[^\?]+)\?=(?:[ ]+(?==\?))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=\\?(?<charset>[^\\?]+)\\?(?<code>[qQbB])\\?(?<text>[^\\?]+)\\?=(?:[ ]+(?==\\?))?', 'g')
const str = `=?utf-8?b?foo?= =?utf-8?B?bar?= more no q encoded =?latin-1?Q?another?=`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}