re = /=\?(?<charset>[^\?]+)\?(?<code>[qQbB])\?(?<text>[^\?]+)\?=(?:[ ]+(?==\?))?/x
str = '=?utf-8?b?foo?= =?utf-8?B?bar?= more no q encoded =?latin-1?Q?another?='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end