$re = '/=\?(?<charset>[^\?]+)\?(?<code>[qQbB])\?(?<text>[^\?]+)\?=(?:[ ]+(?==\?))?/Ux';
$str = '=?utf-8?b?foo?= =?utf-8?B?bar?= more no q encoded =?latin-1?Q?another?=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);