using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^14:00\b[^]]*XXCODE[^]]*error[^]]*]";
string input = @"14:00:01 | some text XXCODE <some text>
some text
]
14:00:02 | some text <some text> XXCODE error
sometext
]
14:00:03 | some text XXCODE <some text>
some text
and more text 412432
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}