import re
regex = re.compile(r"^14:00\b[^]]*XXCODE[^]]*error[^]]*]", flags=re.MULTILINE)
test_str = ("14:00:01 | some text XXCODE <some text> \n"
"some text \n"
"] \n"
"14:00:02 | some text <some text> XXCODE error \n"
"sometext\n"
"]\n"
"14:00:03 | some text XXCODE <some text> \n"
"some text\n"
"and more text 412432 \n"
"]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")