$re = '/^14:00\b[^]]*XXCODE[^]]*error[^]]*]/m';
$str = '14:00:01 | some text XXCODE <some text>
some text
]
14:00:02 | some text <some text> XXCODE error
sometext
]
14:00:03 | some text XXCODE <some text>
some text
and more text 412432
]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);