using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{3})";
string substitution = @"$1,";
string input = @"1234565588885550";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}