const regex = /(\d{3})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3})', 'g')
const str = `1234565588885550`;
const subst = `$1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);