import Foundation
let pattern = #"(\d{3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1234565588885550"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)