package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{3})`)
var str = `1234565588885550`
var substitution = "$1,"
fmt.Println(re.ReplaceAllString(str, substitution))
}