use strict;
my $str = 'SyndromeA, whatever, some stuff, autosomal recessive; DiseaseB, some other stuff, autosomal dominant
currently just looking for the words "syndrome" and "autosomal dominant", but in this example it\'s wrong since SyndromeA is not autosomal dominant, but I\'m getting this line regardless.';
my $regex = qr/syndrome|autosomal dominant/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}