// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)syndrome|autosomal dominant").unwrap();
let string = "SyndromeA, whatever, some stuff, autosomal recessive; DiseaseB, some other stuff, autosomal dominant
currently just looking for the words \"syndrome\" and \"autosomal dominant\", but in this example it's wrong since SyndromeA is not autosomal dominant, but I'm getting this line regardless.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}