re = /syndrome|autosomal dominant/m
str = 'SyndromeA, whatever, some stuff, autosomal recessive; DiseaseB, some other stuff, autosomal dominant
currently just looking for the words "syndrome" and "autosomal dominant", but in this example it\'s wrong since SyndromeA is not autosomal dominant, but I\'m getting this line regardless.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end