$re = '/syndrome|autosomal dominant/m';
$str = 'SyndromeA, whatever, some stuff, autosomal recessive; DiseaseB, some other stuff, autosomal dominant
currently just looking for the words "syndrome" and "autosomal dominant", but in this example it\'s wrong since SyndromeA is not autosomal dominant, but I\'m getting this line regardless.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);