re = /(\d+)\.?(\d*) \/ (\d+)\.?(\d*)/m
str = '4.422 / 9.500
4.422 / 9500
231 / 9.500
231 / 9500'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end