using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w-]+)(\..*)?$";
string input = @"../dir1/dir2/dir3/filename1.tar.gz
../dir1/dir2/dir3/filename2.tar
../dir1/dir2/dir3/filename3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}