package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\w-]+)(\..*)?$`)
var str = `../dir1/dir2/dir3/filename1.tar.gz
../dir1/dir2/dir3/filename2.tar
../dir1/dir2/dir3/filename3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}