re = /([\w-]+)(\..*)?$/m
str = '../dir1/dir2/dir3/filename1.tar.gz
../dir1/dir2/dir3/filename2.tar
../dir1/dir2/dir3/filename3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end