const regex = /\+380 \((93|73|96|97|99|95|50|67)\) \d{3}-\d{2}-\d{2}/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+380 \\((93|73|96|97|99|95|50|67)\\) \\d{3}-\\d{2}-\\d{2}', 'gmu')
const str = `+380 (93) 009-51-65`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}