import re
regex = re.compile(r"\+380 \((93|73|96|97|99|95|50|67)\) \d{3}-\d{2}-\d{2}", flags=re.MULTILINE | re.UNICODE)
test_str = "+380 (93) 009-51-65"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")