re = /\+380 \((93|73|96|97|99|95|50|67)\) \d{3}-\d{2}-\d{2}/m
str = '+380 (93) 009-51-65'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end