package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{3})(-|.) ?(\d{3})[.-](\d{3,4})`)
var str = `Frank . 938-345-678
Thomas (345) 654.5654
TC 435.566.333
Rick 245-345.3453`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}