const regex = /(\d{3})(-|.) ?(\d{3})[.-](\d{3,4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3})(-|.) ?(\\d{3})[.-](\\d{3,4})', 'gm')
const str = `Frank . 938-345-678
Thomas (345) 654.5654
TC 435.566.333
Rick 245-345.3453`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}