import re
regex = re.compile(r"(\d{3})(-|.) ?(\d{3})[.-](\d{3,4})", flags=re.MULTILINE)
test_str = ("Frank . 938-345-678\n"
"Thomas (345) 654.5654\n"
"TC 435.566.333\n"
"Rick 245-345.3453")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")