#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(100%|\d+)x(100%|\d+)$"
Local $sString = "100%x99%" & @CRLF & _
"100%x99" & @CRLF & _
"100%x100%" & @CRLF & _
"100x100" & @CRLF & _
"100%x100" & @CRLF & _
"99x99" & @CRLF & _
"99%x100" & @CRLF & _
"99x99%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")