import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(100%|\\d+)x(100%|\\d+)$";
final String string = "100%x99%\n"
+ "100%x99\n"
+ "100%x100%\n"
+ "100x100\n"
+ "100%x100\n"
+ "99x99\n"
+ "99%x100\n"
+ "99x99%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}