re = /(100%|\d+)x(100%|\d+)$/m
str = '100%x99%
100%x99
100%x100%
100x100
100%x100
99x99
99%x100
99x99%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end