package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(100%|\d+)x(100%|\d+)$`)
var str = `100%x99%
100%x99
100%x100%
100x100
100%x100
99x99
99%x100
99x99%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}