#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[a-z].*[0-9]|[0-9].*[a-z]"
Local $sString = "a" & @CRLF & _
"abc" & @CRLF & _
"32" & @CRLF & _
"9991" & @CRLF & _
"---aaa--aa" & @CRLF & _
"abc123" & @CRLF & _
"ff9a" & @CRLF & _
"82foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")