import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z].*[0-9]|[0-9].*[a-z]";
final String string = "a\n"
+ "abc\n"
+ "32\n"
+ "9991\n"
+ "---aaa--aa\n"
+ "abc123\n"
+ "ff9a\n"
+ "82foo";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}