$re = '/[a-z].*[0-9]|[0-9].*[a-z]/i';
$str = 'a
abc
32
9991
---aaa--aa
abc123
ff9a
82foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);