package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[a-z].*[0-9]|[0-9].*[a-z]`)
var str = `a
abc
32
9991
---aaa--aa
abc123
ff9a
82foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}