#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*?((?=Part1)|(?=Part2))|(?=Part3)|(?=Part4)"
Local $sString = "MatchOnlyMe! Part1 Part2 Part3 Part4" & @CRLF & _
"MatchOnlyMe! Part2 Part3 Part4" & @CRLF & _
"MatchOnlyMe! Part2 Part3" & @CRLF & _
"MatchOnlyMe! Part1 Part3 Part4" & @CRLF & _
"MatchOnlyMe! Part3 Part4" & @CRLF & _
"MatchOnlyMe! Part4" & @CRLF & _
"MatchOnlyMe! Part2" & @CRLF & _
"MatchOnlyMe! Part2 Part4" & @CRLF & _
"MatchOnlyMe! Part1 Part4" & @CRLF & _
"MatchOnlyMe! Part1 Part2 Part4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")