import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?((?=Part1)|(?=Part2))|(?=Part3)|(?=Part4)";
final String string = "MatchOnlyMe! Part1 Part2 Part3 Part4\n"
+ "MatchOnlyMe! Part2 Part3 Part4\n"
+ "MatchOnlyMe! Part2 Part3\n"
+ "MatchOnlyMe! Part1 Part3 Part4\n"
+ "MatchOnlyMe! Part3 Part4\n"
+ "MatchOnlyMe! Part4\n"
+ "MatchOnlyMe! Part2\n"
+ "MatchOnlyMe! Part2 Part4\n"
+ "MatchOnlyMe! Part1 Part4\n"
+ "MatchOnlyMe! Part1 Part2 Part4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}