$re = '/.*?((?=Part1)|(?=Part2))|(?=Part3)|(?=Part4)/';
$str = 'MatchOnlyMe! Part1 Part2 Part3 Part4
MatchOnlyMe! Part2 Part3 Part4
MatchOnlyMe! Part2 Part3
MatchOnlyMe! Part1 Part3 Part4
MatchOnlyMe! Part3 Part4
MatchOnlyMe! Part4
MatchOnlyMe! Part2
MatchOnlyMe! Part2 Part4
MatchOnlyMe! Part1 Part4
MatchOnlyMe! Part1 Part2 Part4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);