import Foundation
let pattern = #".*?((?=Part1)|(?=Part2))|(?=Part3)|(?=Part4)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
MatchOnlyMe! Part1 Part2 Part3 Part4
MatchOnlyMe! Part2 Part3 Part4
MatchOnlyMe! Part2 Part3
MatchOnlyMe! Part1 Part3 Part4
MatchOnlyMe! Part3 Part4
MatchOnlyMe! Part4
MatchOnlyMe! Part2
MatchOnlyMe! Part2 Part4
MatchOnlyMe! Part1 Part4
MatchOnlyMe! Part1 Part2 Part4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)