import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(-?)(\\d{1,})((\\.\\d{0,2})?))$";
final String string = "123.09\n"
+ "123.2345\n"
+ "123.09\n"
+ "-12.23\n"
+ "-100\n"
+ "100\n\n"
+ "12356\n"
+ "123567678\n"
+ "0\n"
+ "0.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}