import re
regex = re.compile(r"(^(-?)(\d{1,})((\.\d{0,2})?))$", flags=re.MULTILINE)
test_str = ("123.09\n"
"123.2345\n"
"123.09\n"
"-12.23\n"
"-100\n"
"100\n\n"
"12356\n"
"123567678\n"
"0\n"
"0.00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")