#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bkey="((?:ktm-(?:(?:e-|[^e]\w*-|e[^d]\w*-)*)abcd(?:(?:-e|-[^e]\w*|-e[^d]\w*)*)|abcd(?:(?:-e|-[^e]\w*|-e[^d]\w*)*)))""
Local $sString = " 1. object{one="ab-vwxc",two="value1",key="abcd-eest-ed-xyz-bnn",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn",four="obsoleteValues"}" & @CRLF & _
" 3. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn-ed",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="abcd-e-xyz-bnn",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="ktm-qg-abcd-eest-xyz-bnn",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="ktm-qg-abcd-ed-xyz-bnn",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="ktm-qg-abcde-eest-xyz-bnn",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="abcd-e",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="test-abcd",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="e-abcd",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="ed-abcd",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="abcd",four="obsoleteValues"}" & @CRLF & _
" 2. object{one="ab-vwxc",two="value1",key="ktm-abcd",four="obsoleteValues"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")