$re = '`\bkey="((?:ktm-(?:(?:e-|[^e]\w*-|e[^d]\w*-)*)abcd(?:(?:-e|-[^e]\w*|-e[^d]\w*)*)|abcd(?:(?:-e|-[^e]\w*|-e[^d]\w*)*)))"`m';
$str = ' 1. object{one="ab-vwxc",two="value1",key="abcd-eest-ed-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn",four="obsoleteValues"}
3. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn-ed",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd-e-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="ktm-qg-abcd-eest-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="ktm-qg-abcd-ed-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="ktm-qg-abcde-eest-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd-e",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="test-abcd",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="e-abcd",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="ed-abcd",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="ktm-abcd",four="obsoleteValues"}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);