import Foundation
let pattern = #"\bkey="((?:ktm-(?:(?:e-|[^e]\w*-|e[^d]\w*-)*)abcd(?:(?:-e|-[^e]\w*|-e[^d]\w*)*)|abcd(?:(?:-e|-[^e]\w*|-e[^d]\w*)*)))""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. object{one="ab-vwxc",two="value1",key="abcd-eest-ed-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn",four="obsoleteValues"}
3. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn-ed",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd-e-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd-eest-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="ktm-qg-abcd-eest-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="ktm-qg-abcd-ed-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="ktm-qg-abcde-eest-xyz-bnn",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd-e",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="test-abcd",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="e-abcd",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="ed-abcd",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="abcd",four="obsoleteValues"}
2. object{one="ab-vwxc",two="value1",key="ktm-abcd",four="obsoleteValues"}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)