// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\bkey="((?:ktm-(?:(?:e-|[^e]\w*-|e[^d]\w*-)*)abcd(?:(?:-e|-[^e]\w*|-e[^d]\w*)*)|abcd(?:(?:-e|-[^e]\w*|-e[^d]\w*)*)))""#).unwrap();
let string = " 1. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-ed-xyz-bnn\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-xyz-bnn\",four=\"obsoleteValues\"}
3. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-xyz-bnn-ed\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-e-xyz-bnn\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-eest-xyz-bnn\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"ktm-qg-abcd-eest-xyz-bnn\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"ktm-qg-abcd-ed-xyz-bnn\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"ktm-qg-abcde-eest-xyz-bnn\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd-e\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"test-abcd\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"e-abcd\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"ed-abcd\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"abcd\",four=\"obsoleteValues\"}
2. object{one=\"ab-vwxc\",two=\"value1\",key=\"ktm-abcd\",four=\"obsoleteValues\"}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}