using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^=\d])\d+(?:\p{Zs}|&\w+;)%";
string input = @"some 50%
and 50 %
now 50 %
47 %
42 %
width=50%
this width=42 % shouldn't match
while a calculation such as result = 27 % may match.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}